Keyword “{id}” required for route error after upgrade to 1.7.5 – php7.2 and prestashop 1.7

Keyword “{id}” required for route error after upgrade to 1.7.5 – php7.2 and prestashop 1.7

After upgrading from 1.7.3.1 to 1.7.5.0 (latest) i cant save the SEO & URLs page (to recreate .htaccess), i always get this errors:

Keyword “{id}” required for route “xipblog-archive-wid-module” (rule: “blog/category/{rewrite}.html”)
Keyword “{id}” required for route “xipblog-tag-wid-module” (rule: “blog/tag/{rewrite}.html”)
Keyword “{id}” required for route “xipblog-single-wid-module” (rule: “blog/post/{rewrite}.html”)

See atached screenshoot’s.

Any ideas how to solve this?

Ok i think i found the solution.
And yes is an theme error/bug/feature.
What i did:
Went to www.domain.com\modules\xipblog (our theme blog module).
Edited xipblog.php.
For example i searched for xipblog-single-wid-module.
and in that array i changed:
‘rule’ =>$main_slug.’/’.$single_slug.’/{rewrite}’.$postfix_slug,
to
‘rule’ =>$main_slug.’/’.$single_slug.’/{id}-{rewrite}’.$postfix_slug,
No more errors on SEO & URLs page and it get saved ok.
Thanks to all for helping. Thanks @khouloudbelguith , thanks @rdy4ever
If anyone nedds more info don’t hesitate to contact me.
Can be marked as solved.

https://github.com/PrestaShop/PrestaShop/issues/12026

关闭菜单